PT-2016-1720

CVE-2016-2412

·

Published

2016-04-18

·

Updated

2016-04-22

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Android versions 4.x through 4.4.3 Android versions 5.0.x through 5.0.1 Android versions 5.1.x through 5.1.0 Android versions 6.x before 2016-04-01
Description The issue is related to the mishandling of certain crashes in the Skia library, specifically in the include/core/SkPostConfig.h file, as used in the System server component of Android. This allows attackers to gain privileges via a crafted application, potentially obtaining Signature or SignatureOrSystem access. The vulnerability is associated with inadequate access control, which can be exploited by a remote attacker to elevate their privileges, leading to a denial of service.
Recommendations For Android versions 4.x through 4.4.3, update to version 4.4.4 or later. For Android versions 5.0.x through 5.0.1, update to version 5.0.2 or later. For Android versions 5.1.x through 5.1.0, update to version 5.1.1 or later. For Android versions 6.x before 2016-04-01, update to a version released after 2016-04-01.
Exploitability
Fix
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾