PT-2016-1729

CVE-2016-2054

·

Published

2016-02-26

·

Updated

2018-10-09

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Xymon versions 4.1.x through 4.3.x before 4.3.25
Description The issue is caused by multiple buffer overflows in the xymond/xymond.c file, allowing remote attackers to execute arbitrary code or cause a denial of service (daemon crash) via a long filename, involving handling a "config" command.
Recommendations For versions 4.1.x through 4.3.x before 4.3.25, update to version 4.3.25 or later to resolve the issue. As a temporary workaround, consider restricting access to the config command in the xymond/xymond.c file until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1161
DLA-488-1
DSA-3495-1
MGASA-2016-0177
Found an issue in the description? Have something to add? Feel free to write us 👾