PT-2016-2028

CVE-2016-1837

·

Published

2016-05-20

·

Updated

2024-06-15

Description by

CVSS 2.0
7.5
High
MetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions libxml2 versions prior to 2.9.4 Apple iOS versions prior to 9.3.2 OS X versions prior to 10.11.5 tvOS versions prior to 9.2.1 watchOS versions prior to 2.2.1
Description The issue is caused by multiple use-after-free vulnerabilities in the htmlParsePubidLiteral and htmlParseSystemiteral functions in libxml2. This allows remote attackers to cause a denial of service via a crafted XML document. Additionally, the vulnerability can be exploited to execute arbitrary code or cause a denial of service due to a buffer overflow, by using a specially formed XML document.
Recommendations For libxml2 versions prior to 2.9.4, update to version 2.9.4 or later. For Apple iOS versions prior to 9.3.2, update to version 9.3.2 or later. For OS X versions prior to 10.11.5, update to version 10.11.5 or later. For tvOS versions prior to 9.2.1, update to version 9.2.1 or later. For watchOS versions prior to 2.2.1, update to version 2.2.1 or later. As a temporary workaround, consider restricting the use of libxml2 until a patch is available. Avoid using the htmlParsePubidLiteral and htmlParseSystemiteral functions in the affected API endpoints until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2017-1240
CESA-2016_1292
DLA-503-1
DSA-3593-1
ECHO-17A8-5EC7-C43D
MGASA-2016-0263
OPENSUSE-SU-2016_1594-1
OPENSUSE-SU-2016_1595-1
OPENSUSE-SU-2024:10192-1
OPENSUSE-SU-2024:10228-1
RHSA-2016:1292
RHSA-2016_1292
SUSE-SU-2016:1538-1
SUSE-SU-2016:1604-1
SUSE-SU-2017:2699-1
SUSE-SU-2017:2700-1
USN-2994-1
Found an issue in the description? Have something to add? Feel free to write us 👾