PT-2016-2085

CVE-2016-4539

·

Published

2016-05-06

·

Updated

2018-10-30

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.5.35 PHP versions 5.6.x prior to 5.6.21 PHP versions 7.x prior to 7.0.6
Description The issue allows remote attackers to cause a denial of service or possibly have other impacts via crafted XML data in the second argument to the xml parse into struct function, leading to a parser level of zero. This is due to a buffer under-read and segmentation fault. The vulnerability can be exploited by a remote attacker using specially formed XML data.
Recommendations For PHP versions prior to 5.5.35, update to version 5.5.35 or later. For PHP versions 5.6.x prior to 5.6.21, update to version 5.6.21 or later. For PHP versions 7.x prior to 7.0.6, update to version 7.0.6 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-499-1
DSA-3602-1
RHSA-2016:2750
SUSE-SU-2016:1504-1
SUSE-SU-2016:1581-1
SUSE-SU-2016:1638-1
USN-2984-1
Found an issue in the description? Have something to add? Feel free to write us 👾