PT-2016-2279

CVE-2016-0755

·

Published

2016-01-27

·

Updated

2024-06-15

Description by

CVSS 3.1
7.3
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Name of the Vulnerable Software and Affected Versions libcurl versions prior to 7.47.0
Description The issue is related to the ConnectionExists function in lib/url.c, which has weaknesses in its authentication procedure. This could allow a remote attacker to authenticate as another user by sending a request. The problem is associated with the improper re-use of NTLM-authenticated proxy connections.
Recommendations For versions prior to 7.47.0, update to version 7.47.0 or later to resolve the issue. As a temporary workaround, consider restricting access to NTLM-authenticated proxy connections to minimize the risk of exploitation. Avoid using the ConnectionExists function in lib/url.c until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1225
DSA-3455-1
MGASA-2016-0050
OPENSUSE-SU-2024:10303-1
SUSE-SU-2016:0340-1
SUSE-SU-2016_0340-1
SUSE-SU-2016:0347-1
SUSE-SU-2016_0347-1
SUSE-SU-2016:0778-1
USN-2882-1
Found an issue in the description? Have something to add? Feel free to write us 👾