PT-2016-2310
CVE-2016-2945
·
Published
2016-07-08
·
Updated
2016-11-28
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
WebSphere Application Server versions 8.5.5.8 through 8.5.5.9
Description
The issue is related to the implementation of the API Discovery server in WebSphere Application Server, which is associated with insufficient access control. This can be exploited by a remote attacker to gain elevated privileges using an external reference in a Swagger document.
Recommendations
For versions 8.5.5.8 through 8.5.5.9, update to Liberty Fix Pack 16.0.0.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the Swagger document to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾