PT-2016-2524
CVE-2016-5261
·
Published
2016-08-03
·
Updated
2024-12-12
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 48.0
Mozilla Firefox ESR versions prior to 45.4
Description
The issue is caused by an integer overflow in the WebSocketChannel class within the WebSockets subsystem. This allows remote attackers to execute arbitrary code or cause a denial of service, resulting in memory corruption, via crafted packets that trigger incorrect buffer-resize operations during buffering.
Recommendations
For Mozilla Firefox versions prior to 48.0, update to version 48.0 or later to resolve the issue.
For Mozilla Firefox ESR versions prior to 45.4, update to version 45.4 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾