PT-2016-2526
CVE-2016-5259
·
Published
2016-08-02
·
Updated
2024-12-12
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 48.0
Firefox ESR 45.x versions prior to 45.3
Description
The issue is related to a use-after-free vulnerability in the
CanonicalizeXPCOMParticipant function. This vulnerability can be exploited by a remote attacker to execute arbitrary code via a script that closes its own Service Worker within a nested sync event loop.Recommendations
For Mozilla Firefox versions prior to 48.0, update to version 48.0 or later.
For Firefox ESR 45.x versions prior to 45.3, update to version 45.3 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾