PT-2016-2531
CVE-2016-5252
·
Published
2016-08-02
·
Updated
2024-12-12
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Mozilla Firefox versions prior to 48.0
Firefox ESR versions prior to 45.3
Description
The issue is caused by a stack-based buffer underflow in the
mozilla::gfx::BasePoint4d function. This can be exploited by a remote attacker using specially crafted two-dimensional graphics data that is mishandled during clipping-region calculations, potentially allowing the execution of arbitrary code.Recommendations
For Mozilla Firefox versions prior to 48.0, update to version 48.0 or later.
For Firefox ESR versions prior to 45.3, update to version 45.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾