PT-2016-2659
CVE-2016-1706
·
Published
2016-07-20
·
Updated
2024-06-15
Description by
CVSS 3.1
9.6
CriticalMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Google Chrome versions prior to 52.0.2743.82
Opera (affected versions not specified)
Description
The issue is related to the PPAPI implementation in Google Chrome and Opera, where the origin of IPC messages to the plugin broker process is not validated. This allows remote attackers to bypass a sandbox protection mechanism via an unexpected message type, related to files such as broker process dispatcher.cc, ppapi plugin process host.cc, ppapi thread.cc, and render frame message filter.cc.
Recommendations
For Google Chrome versions prior to 52.0.2743.82, update to version 52.0.2743.82 or later to resolve the issue.
For Opera, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
Found an issue in the description? Have something to add? Feel free to write us 👾