PT-2016-3059

CVE-2016-9119

·

Published

2016-11-14

·

Updated

2022-05-17

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions MoinMoin versions prior to 1.9.8
Description The issue is related to a cross-site scripting (XSS) vulnerability in the link dialogue of the GUI editor. This allows remote attackers to inject arbitrary web script or HTML via unspecified vectors. The vulnerability exists due to a lack of protection for the web page structure, which can be exploited by a remote attacker to inject arbitrary code.
Recommendations For versions prior to 1.9.8, update to version 1.9.8 or later to resolve the issue. As a temporary workaround, consider disabling the link dialogue feature in the GUI editor until a patch is available. Restrict access to the GUI editor to minimize the risk of exploitation. Avoid using the GUI editor for sensitive operations until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-5FQ5-PFV8-MRFV
DLA-717-1
DSA-3715-1
PYSEC-2017-20
USN-3137-1
Found an issue in the description? Have something to add? Feel free to write us 👾