PT-2016-3286
CVE-2018-11645
·
Published
2016-10-05
·
Updated
2019-08-30
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions prior to 9.21rc1
Description
The issue is related to the zfile.c library in the PostScript/PDF interpreter Ghostscript, which is connected to the status command. Even when the dSAFER sandbox is used, the vulnerability can be exploited. This allows a remote attacker to determine the existence and size of arbitrary files.
Recommendations
For versions prior to 9.21rc1, update to version 9.21rc1 or later to resolve the issue. As a temporary workaround, consider restricting access to the
zfile.c library until a patch is available. Avoid using the status command in the affected Ghostscript interpreter until the issue is resolved. Found an issue in the description? Have something to add? Feel free to write us 👾