PT-2016-3325
CVE-2016-10199
·
Published
2016-12-01
·
Updated
2026-10-14
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Gstreamer versions prior to 1.10.3
Description
The issue is related to the qtdemux tag add str full function in the gst-plugins-good plugin of the Gstreamer multimedia framework. It involves an out-of-bounds operation in memory, which can be exploited by a remote attacker to cause a denial of service. This can be achieved through a crafted tag value, leading to a crash.
Recommendations
For versions prior to 1.10.3, update to version 1.10.3 or later to resolve the issue. As a temporary workaround, consider restricting the use of the qtdemux tag add str full function until a patch is available.
Found an issue in the description? Have something to add? Feel free to write us 👾