PT-2016-3351
CVE-2016-20011
·
Published
2016-10-09
·
Updated
2021-10-25
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
libgrss versions prior to 0.7.1
Description
The issue is related to the failure of libgrss to perform TLS certificate verification when downloading feeds. This is due to the default behavior of SoupSessionSync, allowing remote attackers to manipulate feed contents without detection. The vulnerability can be exploited by a remote attacker to impact data integrity.
Recommendations
For libgrss versions prior to 0.7.1, update to version 0.7.1 or later to resolve the issue. As a temporary workaround, consider disabling the use of SoupSessionSync until a patch is available. Restrict access to feeds from untrusted sources to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾