PT-2016-3368
CVE-2016-7130
·
Published
2016-09-11
·
Updated
2018-01-05
Description by
CVSS 2.0
7.8
HighMetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.25
PHP versions 7.x prior to 7.0.10
Description
The issue is related to the
php wddx pop element function, which can cause a denial of service due to a NULL pointer dereference and application crash when handling an invalid base64 binary value. This can be triggered by a wddx deserialize call that mishandles a binary element in a wddxPacket XML document. The vulnerability may allow remote attackers to have unspecified other impact.Recommendations
For PHP versions prior to 5.6.25, update to version 5.6.25 or later.
For PHP versions 7.x prior to 7.0.10, update to version 7.0.10 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾