PT-2016-3369

CVE-2016-7129

·

Published

2016-09-11

·

Updated

2018-01-05

Description by

CVSS 2.0
10
Critical
MetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.25 PHP versions 7.x prior to 7.0.10
Description The issue is related to the php wddx process data function, which does not properly check input data. This can be exploited by remote attackers to cause a denial of service, potentially resulting in a segmentation fault, by providing an invalid ISO 8601 time value. This can be demonstrated through a wddx deserialize call that mishandles a dateTime element in a wddxPacket XML document.
Recommendations For PHP versions prior to 5.6.25, update to version 5.6.25 or later. For PHP versions 7.x prior to 7.0.10, update to version 7.0.10 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-749-1
DSA-3689-1
OPENSUSE-SU-2016_2337-1
OPENSUSE-SU-2016_2451-1
RHSA-2016:2750
SUSE-SU-2016:2328-1
SUSE-SU-2016:2408-1
SUSE-SU-2016:2459-1
SUSE-SU-2016:2460-1
SUSE-SU-2016:2460-2
USN-3095-1
Found an issue in the description? Have something to add? Feel free to write us 👾