PT-2016-3377

CVE-2016-7418

·

Published

2016-09-17

·

Updated

2018-05-04

Description by

CVSS 2.0
7.8
High
MetricsAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions PHP versions prior to 5.6.26 PHP 7.x versions prior to 7.0.11
Description The issue allows remote attackers to cause a denial of service or possibly have other unspecified impacts through an incorrect boolean element in a wddxPacket XML document. This leads to mishandling in a wddx deserialize call, resulting in invalid pointer access and out-of-bounds read. The problem is caused by a buffer overflow in the php wddx push element function.
Recommendations For PHP versions prior to 5.6.26, update to version 5.6.26 or later. For PHP 7.x versions prior to 7.0.11, update to version 7.0.11 or later. As a temporary workaround, consider restricting the use of the php wddx push element function until a patch is available. Avoid using incorrect boolean elements in wddxPacket XML documents to minimize the risk of exploitation.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-749-1
DSA-3689-1
MGASA-2016-0319
OPENSUSE-SU-2016_2444-1
OPENSUSE-SU-2016_2540-1
RHSA-2018:1296
SUSE-SU-2016:2459-1
SUSE-SU-2016:2460-1
SUSE-SU-2016:2460-2
SUSE-SU-2016:2461-1
SUSE-SU-2016:2477-1
SUSE-SU-2016:2477-2
USN-3095-1
Found an issue in the description? Have something to add? Feel free to write us 👾