PT-2016-3381
CVE-2016-7413
·
Published
2016-09-17
·
Updated
2018-05-04
Description by
CVSS 2.0
10
CriticalMetricsAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.6.26
PHP versions 7.x prior to 7.0.11
Description
The issue is related to a use-after-free vulnerability in the
wddx stack destroy function. This vulnerability can be exploited by remote attackers via a wddxPacket XML document that lacks an end-tag for a recordset field element, leading to mishandling in a wddx deserialize call. The exploitation may cause a denial of service or possibly have other unspecified impacts.Recommendations
For PHP versions prior to 5.6.26, update to version 5.6.26 or later.
For PHP versions 7.x prior to 7.0.11, update to version 7.0.11 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾