PT-2016-3399
CVE-2016-6174
·
Published
2016-07-12
·
Updated
2020-06-03
Description by
CVSS 2.0
9.3
HighMetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Invision Power Services IPS Community Suite versions prior to 4.1.13
Description
The issue is related to insecure privilege management in the applications/core/modules/front/system/content.php component of Invision Power Board software when used with certain versions of PHP. This allows remote attackers to execute arbitrary code via the
content class parameter.Recommendations
For versions prior to 4.1.13, update to version 4.1.13 or later to resolve the issue. As a temporary workaround, consider restricting access to the
content class parameter in the affected API endpoint until the issue is resolved.Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾