PT-2016-3414
CVE-2016-3185
·
Published
2016-03-22
·
Updated
2016-12-01
Description by
CVSS 2.0
9.4
HighMetricsAV:N/AC:L/Au:N/C:C/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions prior to 5.4.44
PHP versions 5.5.x prior to 5.5.28
PHP versions 5.6.x prior to 5.6.12
PHP versions 7.x prior to 7.0.4
Description
The issue allows remote attackers to obtain sensitive information from process memory or cause a denial of service. This is related to the
SoapClient:: call method and is caused by insufficient input validation in the make http soap request function, allowing exploitation through crafted serialized cookies data.Recommendations
For PHP versions prior to 5.4.44, update to version 5.4.44 or later.
For PHP versions 5.5.x prior to 5.5.28, update to version 5.5.28 or later.
For PHP versions 5.6.x prior to 5.6.12, update to version 5.6.12 or later.
For PHP versions 7.x prior to 7.0.4, update to version 7.0.4 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾