PT-2016-3841

CVE-2015-7939

·

Published

2016-01-06

·

Updated

2016-01-18

Description by

CVSS 2.0
9.3
High
MetricsAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Unitronics VisiLogic OPLC IDE versions prior to 9.8.09
Description The issue is related to a heap-based buffer overflow that can be triggered by a long vlp filename, allowing remote attackers to execute arbitrary code. This is a remote code execution vulnerability related to file parsing.
Recommendations For versions prior to 9.8.09, update to version 9.8.09 or later to resolve the issue. As a temporary workaround, consider restricting the length of vlp filenames to prevent exploitation until a patch is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ZDI-16-001
Found an issue in the description? Have something to add? Feel free to write us 👾