PT-2016-3843

CVE-2015-7987

·

Published

2016-06-26

·

Updated

2019-06-19

Description by

CVSS 2.0
6.8
Medium
MetricsAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions mDNSResponder versions prior to 625.41.2
Description The issue involves multiple buffer overflows that allow remote attackers to read or write to out-of-bounds memory locations. This can be achieved through various vectors, including the GetValueForIPv4Addr, GetValueForMACAddr, rfc3110 import, or CopyNSEC3ResourceRecord functions.
Recommendations For versions prior to 625.41.2, update to version 625.41.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the functions GetValueForIPv4Addr, GetValueForMACAddr, rfc3110 import, and CopyNSEC3ResourceRecord until a patch is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾