PT-2016-4027

CVE-2015-8797

·

Published

2016-02-15

·

Updated

2022-05-17

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Apache Solr versions prior to 5.3.1
Description A cross-site scripting (XSS) issue exists, allowing remote attackers to inject arbitrary web script or HTML. This is achieved via the entry parameter to a plugins/cache URI in the stats page of the Admin UI.
Recommendations For versions prior to 5.3.1, update to version 5.3.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the plugins/cache URI in the Admin UI to minimize the risk of exploitation. Avoid using the entry parameter in the affected URI until the issue is resolved.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-V6GF-X8FP-532V
Found an issue in the description? Have something to add? Feel free to write us 👾