PT-2016-4400
CVE-2016-0747
·
Published
2016-01-26
·
Updated
2024-06-15
Description by
CVSS 3.1
5.3
MediumMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Name of the Vulnerable Software and Affected Versions
nginx versions 1.8.0 through 1.8.1
nginx versions 1.9.x through 1.9.10
Description
The issue is related to the resolver in nginx not properly limiting CNAME resolution. This allows remote attackers to cause a denial of service by consuming worker process resources via vectors related to arbitrary name resolution.
Recommendations
For nginx versions 1.8.0 through 1.8.1, update to version 1.8.1 or later to resolve the issue.
For nginx versions 1.9.x through 1.9.10, update to version 1.9.10 or later to resolve the issue.
As a temporary workaround, consider restricting access to the resolver to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾