PT-2016-4914

CVE-2016-1901

·

Published

2016-01-20

·

Updated

2024-06-15

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions CGit versions prior to 0.12
Description The issue is related to an integer overflow in the authenticate post function, which can be triggered by a large value in the Content-Length HTTP header. This leads to a buffer overflow, allowing remote attackers to have an unspecified impact.
Recommendations For versions prior to 0.12, update to version 0.12 or later to resolve the issue. As a temporary workaround, consider restricting access to the authenticate post function to minimize the risk of exploitation. Avoid using large values in the Content-Length HTTP header until the issue is resolved.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DSA-3545-1
MGASA-2016-0047
OPENSUSE-SU-2024:10137-1
Found an issue in the description? Have something to add? Feel free to write us 👾