PT-2016-5015
CVE-2016-2098
·
Published
2016-03-09
·
Updated
2024-06-15
Description by
CVSS 2.0
7.5
HighMetricsAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Ruby on Rails versions 3.2.x through 3.2.22.1
Ruby on Rails versions 4.0.x through 4.1.14.1
Ruby on Rails versions 4.2.x through 4.2.5.1
Description
The issue allows remote attackers to execute arbitrary Ruby code by leveraging an application's unrestricted use of the render method.
Recommendations
For versions 3.2.x through 3.2.22.1, update to version 3.2.22.2 or later.
For versions 4.0.x through 4.1.14.1, update to version 4.1.14.2 or later.
For versions 4.2.x through 4.2.5.1, update to version 4.2.5.2 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾