PT-2016-5032

CVE-2016-2152

·

Published

2016-03-25

·

Updated

2022-05-13

Description by

CVSS 3.1
6.1
Medium
MetricsAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Moodle versions prior to 2.6.11 Moodle versions 2.7.x before 2.7.13 Moodle versions 2.8.x before 2.8.11 Moodle versions 2.9.x before 2.9.5 Moodle versions 3.0.x before 3.0.3
Description The issue allows remote attackers to inject arbitrary web script or HTML via an external DB profile field, which can lead to cross-site scripting (XSS) attacks. This occurs due to multiple XSS vulnerabilities in the auth/db/auth.php file.
Recommendations For Moodle versions prior to 2.6.11, update to version 2.6.11 or later. For Moodle versions 2.7.x before 2.7.13, update to version 2.7.13 or later. For Moodle versions 2.8.x before 2.8.11, update to version 2.8.11 or later. For Moodle versions 2.9.x before 2.9.5, update to version 2.9.5 or later. For Moodle versions 3.0.x before 3.0.3, update to version 3.0.3 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
GHSA-6MXM-WPQV-675H
MGASA-2016-0122
Found an issue in the description? Have something to add? Feel free to write us 👾