PT-2016-5174
CVE-2016-2512
·
Published
2016-03-01
·
Updated
2024-06-15
Description by
CVSS 3.1
7.4
HighMetricsAV:N/AC:L/PR:N/UI:R/S:C/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
Django versions 1.8.0 through 1.8.9
Django versions 1.9.0 through 1.9.2
Description
The issue allows remote attackers to redirect users to arbitrary web sites and conduct phishing attacks or possibly conduct cross-site scripting (XSS) attacks via a URL containing basic authentication. This is demonstrated by a URL such as
http://mysite.example.com@attacker.com, which could be used to trick users into revealing sensitive information.Recommendations
For Django versions 1.8.0 through 1.8.9, update to version 1.8.10 or later.
For Django versions 1.9.0 through 1.9.2, update to version 1.9.3 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾