PT-2016-5179
CVE-2016-2521
·
Published
2016-02-27
·
Updated
2017-09-08
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Wireshark versions 1.12.x through 1.12.9
Wireshark versions 2.0.x through 2.0.1
Description
The issue is related to an untrusted search path vulnerability in the WiresharkApplication class. This vulnerability allows local users to gain privileges via a Trojan horse riched20.dll.dll file in the current working directory. The vulnerability is related to the use of QLibrary.
Recommendations
For Wireshark versions 1.12.x through 1.12.9, update to version 1.12.10 or later.
For Wireshark versions 2.0.x through 2.0.1, update to version 2.0.2 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾