PT-2016-5193

CVE-2016-2537

·

Published

2016-02-23

·

Updated

2018-07-31

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions is-my-json-valid versions prior to 2.17.2 is-my-json-valid versions prior to 1.4.1
Description The issue is related to an incorrect regular expression in the is-my-json-valid package, which can cause a denial of service (blocked event loop) via a crafted string. This can be exploited by remote attackers. The vulnerability is also described as a regular expression denial of service (ReDoS) via the email validation function.
Recommendations Update to version 1.4.1 or later. Update to version 2.17.2 or later.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-CCQ6-3QX5-VMQX
GHSA-F522-FFG8-J8R6
Found an issue in the description? Have something to add? Feel free to write us 👾