PT-2016-6024

CVE-2016-4564

·

Published

2016-03-30

·

Updated

2016-11-21

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions ImageMagick versions prior to 6.9.4-0 ImageMagick versions 7.x prior to 7.0.1-2
Description The issue is related to the DrawImage function in MagickCore/draw.c, which makes an incorrect function call when attempting to locate the next token. This can be exploited by remote attackers using a crafted file, potentially causing a denial of service due to a buffer overflow and application crash, or possibly having other unspecified impacts.
Recommendations For ImageMagick versions prior to 6.9.4-0, update to version 6.9.4-0 or later. For ImageMagick versions 7.x prior to 7.0.1-2, update to version 7.0.1-2 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2016-1289
DLA-731-1
DSA-3652-1
OPENSUSE-SU-2016_1748-1
OPENSUSE-SU-2016_1833-1
SUSE-SU-2016:1782-1
SUSE-SU-2016:1784-1
USN-3131-1
Found an issue in the description? Have something to add? Feel free to write us 👾