PT-2016-6031
CVE-2016-4574
·
Published
2016-05-13
·
Updated
2024-06-15
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Libksba versions prior to 1.3.4
Description
The issue is caused by an off-by-one error in the
append utf8 value function within the DN decoder (dn.c) in Libksba. This error allows remote attackers to cause a denial of service (out-of-bounds read) via invalid utf-8 encoded data.Recommendations
For versions prior to 1.3.4, update to version 1.3.4 or later to resolve the issue. As a temporary workaround, consider restricting the input of utf-8 encoded data to prevent exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾