PT-2016-6675
CVE-2016-5766
·
Published
2016-06-24
·
Updated
2024-06-15
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
GD Graphics Library versions prior to 2.2.3
PHP versions prior to 5.5.37
PHP versions 5.6.x prior to 5.6.23
PHP versions 7.x prior to 7.0.8
Description
The issue is related to an integer overflow in the
gd2GetHeader function, which can be exploited by remote attackers using crafted chunk dimensions in an image. This can lead to a denial of service, causing a heap-based buffer overflow and application crash, or possibly have other unspecified impacts.Recommendations
For GD Graphics Library versions prior to 2.2.3, update to version 2.2.3 or later.
For PHP versions prior to 5.5.37, update to version 5.5.37 or later.
For PHP versions 5.6.x prior to 5.6.23, update to version 5.6.23 or later.
For PHP versions 7.x prior to 7.0.8, update to version 7.0.8 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾