PT-2016-6792

CVE-2016-6187

·

Published

2016-07-28

·

Updated

2025-09-29

Description by

CVSS 3.1
7.8
High
MetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 4.6.5
Description The issue concerns the apparmor setprocattr function in the Linux kernel, which does not validate the buffer size. This allows local users to gain privileges by triggering an AppArmor setprocattr hook.
Recommendations For Linux kernel versions prior to 4.6.5, update to version 4.6.5 or later to resolve the issue.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALSA-2025_16880
ALT-PU-2016-1795
OPENSUSE-SU-2024:10128-1
Found an issue in the description? Have something to add? Feel free to write us 👾