PT-2016-6796
CVE-2016-6197
·
Published
2016-06-22
·
Updated
2019-12-27
Description by
CVSS 3.1
5.5
MediumMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.6
Description
The issue is related to the OverlayFS filesystem implementation in the Linux kernel. It does not properly verify the upper dentry before proceeding with unlink and rename system-call processing. This allows local users to cause a denial of service (system crash) via a rename system call that specifies a self-hardlink.
Recommendations
For Linux kernel versions prior to 4.6, update to version 4.6 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾