PT-2016-6813

CVE-2016-6263

·

Published

2016-07-21

·

Updated

2021-06-29

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions libidn versions prior to 1.33
Description The issue allows context-dependent attackers to cause a denial of service, resulting in an out-of-bounds read and crash, via crafted UTF-8 data. This is due to a problem in the stringprep utf8 nfkc normalize function.
Recommendations For versions prior to 1.33, update to version 1.33 or later to resolve the issue. As a temporary workaround, consider restricting the input of crafted UTF-8 data to the stringprep utf8 nfkc normalize function until a patch is available.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Weakness enumeration
Related identifiers
ALT-PU-2016-1770
ALT-PU-2018-1106
DLA-582-1
DSA-3658-1
MGASA-2016-0269
OPENSUSE-SU-2024:10566-1
SUSE-SU-2016:2079-1
SUSE-SU-2016:2291-1
SUSE-SU-2017:2699-1
SUSE-SU-2017:2700-1
USN-3068-1
Found an issue in the description? Have something to add? Feel free to write us 👾