PT-2016-6838

CVE-2016-6354

·

Published

2016-08-12

·

Updated

2024-12-12

Description by

CVSS 3.1
9.8
Critical
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Flex versions prior to 2.6.1
Description A heap-based buffer overflow issue exists in the yy get next buffer function, potentially allowing attackers to cause a denial of service or possibly execute arbitrary code via certain vectors involving num to read.
Recommendations For versions prior to 2.6.1, update to version 2.6.1 or later to resolve the issue.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
ALT-PU-2019-1003
DSA-3653-1
DSA-3653-2
MGASA-2016-0396
OPENSUSE-SU-2016:2253-1
OPENSUSE-SU-2016:2254-1
OPENSUSE-SU-2017_0356-1
OPENSUSE-SU-2024:10071-1
OPENSUSE-SU-2024:10218-1
OPENSUSE-SU-2024:10230-1
OPENSUSE-SU-2024:14572-1
SUSE-SU-2016:2061-1
SUSE-SU-2016:2131-1
SUSE-SU-2016:2195-1
SUSE-SU-2016:2397-1
SUSE-SU-2017:1442-1
SUSE-SU-2017_1442-1
Found an issue in the description? Have something to add? Feel free to write us 👾