PT-2016-7519
CVE-2016-8602
·
Published
2016-10-12
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Ghostscript versions prior to 9.21
Description
The issue allows remote attackers to cause a denial of service or possibly execute arbitrary code via a crafted Postscript document. This is achieved by calling the .sethalftone5 function with an empty operand stack.
Recommendations
For Ghostscript versions prior to 9.21, update to version 9.21 or later to resolve the issue. As a temporary workaround, consider restricting the use of the .sethalftone5 function in psi/zht2.c to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾