PT-2016-7782
CVE-2016-9576
·
Published
2016-12-11
·
Updated
2024-06-15
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 4.8.14
Description
The issue allows local users to read or write to arbitrary kernel memory locations or cause a denial of service by leveraging access to a /dev/sg device. This is due to the blk rq map user iov function in block/blk-map.c not properly restricting the type of iterator, leading to potential use-after-free conditions.
Recommendations
For Linux kernel versions prior to 4.8.14, update to version 4.8.14 or later to resolve the issue. As a temporary workaround, consider restricting access to /dev/sg devices to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾