PT-2016-7861
CVE-2016-9878
·
Published
2016-12-29
·
Updated
2022-04-11
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Pivotal Spring Framework versions prior to 3.2.18
Pivotal Spring Framework versions 4.2.x prior to 4.2.9
Pivotal Spring Framework versions 4.3.x prior to 4.3.5
Description
The issue allows directory traversal attacks due to insufficient sanitization of paths provided to the ResourceServlet.
Recommendations
For versions prior to 3.2.18, update to version 3.2.18 or later.
For versions 4.2.x prior to 4.2.9, update to version 4.2.9 or later.
For versions 4.3.x prior to 4.3.5, update to version 4.3.5 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾