PT-2016-7873
CVE-2016-9901
·
Published
2016-12-13
·
Updated
2024-12-12
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Firefox ESR versions prior to 45.6
Firefox versions prior to 50.1
Description
The issue allows HTML tags received from the Pocket server to be processed without sanitization, enabling any JavaScript code to be executed in the "about:pocket-saved" page. This gives the code access to Pocket's messaging API through HTML injection.
Recommendations
For Firefox ESR versions prior to 45.6, update to version 45.6 or later.
For Firefox versions prior to 50.1, update to version 50.1 or later.
Exploitability
Exploit
Fix
Impacts
Researchers
Vendors
Affected products
Found an issue in the description? Have something to add? Feel free to write us 👾