PT-2017-10390

CVE-2016-9933

·

Published

2016-12-13

·

Updated

2018-05-04

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions GD Graphics Library versions prior to 2.2.2 PHP versions prior to 5.6.28 and 7.x prior to 7.0.13
Description The issue is related to a stack consumption vulnerability in the gdImageFillToBorder function. This vulnerability can be exploited by remote attackers to cause a denial of service, resulting in a segmentation violation. The exploitation occurs when a crafted imagefilltoborder call is made, triggering the use of a negative color value.
Recommendations For GD Graphics Library versions prior to 2.2.2, update to version 2.2.2 or later. For PHP versions prior to 5.6.28, update to version 5.6.28 or later. For PHP 7.x versions prior to 7.0.13, update to version 7.0.13 or later.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
DLA-758-1
DSA-3732-1
DSA-3732-2
DSA-3751-1
RHSA-2018:1296
SUSE-SU-2016:3211-1
SUSE-SU-2016_3211-1
SUSE-SU-2016:3251-1
SUSE-SU-2016_3251-1
SUSE-SU-2017:0017-1
SUSE-SU-2017_0017-1
SUSE-SU-2017:0038-1
SUSE-SU-2017_0038-1
SUSE-SU-2017:0109-1
USN-3213-1
Found an issue in the description? Have something to add? Feel free to write us 👾