PT-2017-10886

CVE-2017-1000189

·

Published

2017-11-17

·

Updated

2018-03-05

Description by

CVSS 3.1
7.5
High
MetricsAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions ejs versions prior to 2.5.5
Description The issue is related to a denial-of-service caused by weak input validation in the ejs.renderFile() function.
Recommendations For versions prior to 2.5.5, update to version 2.5.5 or later to resolve the issue. As a temporary workaround, consider restricting the use of the ejs.renderFile() function until a patch is applied.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
GHSA-6X77-RPQF-J6MW
Found an issue in the description? Have something to add? Feel free to write us 👾