PT-2017-10936
CVE-2017-1000243
·
Published
2017-11-01
·
Updated
2022-05-13
Description by
CVSS 3.1
4.3
MediumMetricsAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Jenkins Favorite Plugin versions 2.1.4 and older
Jenkins Favorite Plugin versions up to and including 2.1.0
However, since '2.1.4 and older' already includes 'up to and including 2.1.0', the most concise form is:
Jenkins Favorite Plugin versions 2.1.4 and older
Description
The issue concerns a lack of permission checks when changing favorite status. This allows any user to set any other user's favorites.
Recommendations
For Jenkins Favorite Plugin versions 2.1.4 and older, update to a version newer than 2.1.4 to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾