PT-2017-11606
CVE-2017-10916
·
Published
2017-07-05
·
Updated
2017-11-04
Description by
CVSS 3.1
7.5
HighMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions
Xen versions prior to 4.9
Description
The issue arises from improper interaction between the vCPU context-switch implementation and the Memory Protection Extensions (MPX) and Protection Key (PKU) features in Xen. This interaction makes it easier for guest OS users to bypass Address Space Layout Randomization (ASLR) and other protection mechanisms.
Recommendations
For Xen versions prior to 4.9, update to version 4.9 or later to resolve the issue.
Found an issue in the description? Have something to add? Feel free to write us 👾