PT-2017-12337

CVE-2017-12072

·

Published

2017-12-20

·

Updated

2019-10-09

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Synology Photo Station versions prior to 6.8.0-3456
Description The issue is related to a cross-site scripting (XSS) vulnerability. This vulnerability allows remote authenticated users to inject arbitrary web scripts or HTML via the id parameter in the PixlrEditorHandler.php file.
Recommendations For versions prior to 6.8.0-3456, update to version 6.8.0-3456 or later to resolve the issue. As a temporary workaround, consider restricting access to the PixlrEditorHandler.php file to minimize the risk of exploitation. Avoid using the id parameter in the affected API endpoint until the issue is resolved.
Exploitability
Fix
Impacts
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾