PT-2017-12376
CVE-2017-12166
·
Published
2017-10-03
·
Updated
2025-03-11
Description by
CVSS 3.1
9.8
CriticalMetricsAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
OpenVPN versions prior to 2.3.18
OpenVPN versions 2.4.x prior to 2.4.4
Description
The issue is related to a buffer overflow vulnerability that can occur when
key-method 1 is used, potentially leading to code execution.Recommendations
For OpenVPN versions prior to 2.3.18, update to version 2.3.18 or later.
For OpenVPN versions 2.4.x prior to 2.4.4, update to version 2.4.4 or later.
Found an issue in the description? Have something to add? Feel free to write us 👾