PT-2017-1321
CVE-2016-4683
·
Published
2017-02-20
·
Updated
2017-02-21
Description by
CVSS 3.1
7.8
HighMetricsAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
macOS versions prior to 10.12.1
Description
The issue involves the
ImageIO component and allows remote attackers to execute arbitrary code or cause a denial of service via a crafted SGI file. This is due to an out-of-bounds memory access, which can lead to an application crash.Recommendations
For macOS versions prior to 10.12.1, update to version 10.12.1 or later to resolve the issue. As a temporary workaround, consider avoiding the use of the
ImageIO component with untrusted SGI files until a patch is applied. Found an issue in the description? Have something to add? Feel free to write us 👾