PT-2017-13985
CVE-2017-15308
·
Published
2017-12-22
·
Updated
2018-08-02
Description by
CVSS 3.1
8.8
HighMetricsAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Huawei iReader app versions prior to 8.0.2.301
Description
The issue is due to insufficient validation on the URL used for loading network data, allowing an attacker to control app access and load malicious websites. This enables the attacker to run code from these webpages.
Recommendations
For versions prior to 8.0.2.301, update to version 8.0.2.301 or later to resolve the issue. As a temporary workaround, consider restricting access to untrusted websites to minimize the risk of exploitation.
Found an issue in the description? Have something to add? Feel free to write us 👾