PT-2017-14570

CVE-2017-16801

·

Published

2017-11-13

·

Updated

2017-12-01

Description by

CVSS 3.1
5.4
Medium
MetricsAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Octopus Deploy versions 3.7.0 through 3.17.13
Description A cross-site scripting (XSS) issue allows remote authenticated users to inject arbitrary web script or HTML via the Step Template Name parameter. This could potentially lead to unauthorized actions on the affected system.
Recommendations For versions 3.7.0 through 3.17.13, update to version 3.17.14 to resolve the issue. As a temporary workaround, consider restricting access to the Step Template Name parameter until the update is applied.
Exploitability
Fix
Impacts
Researchers
Vendors
Affected products
Related identifiers
Found an issue in the description? Have something to add? Feel free to write us 👾